Metal Guitarist Forums banner
1 - 13 of 13 Posts

·
Premium Member
Joined
·
1,392 Posts
Discussion Starter · #5 ·
Have you tried Revalver yet?
I want either Amplitube or Revalver and can't decide which one to get :s
I tried Revalver quite a while ago and absolutely hated it - then I got Amplitube and haven't looked back. Granted, I'm endorsed, but still... :D
 

·
Argh
Joined
·
2,658 Posts
I tried Revalver quite a while ago and absolutely hated it - then I got Amplitube and haven't looked back. Granted, I'm endorsed, but still... :D
I that case I'll trust that you're impartial ;)
I'm gonna wait until I get my new Mac in January, but i'll probs go with Amplitube. The only thing is, all of these clips have been fairly low gain lead tones. How does it do for higher gain stuff. Not necessarily modern 'brutal' metal, but harder rock tones etc. ?

Ps. Sorry for all the questions but it's not really something I can try before I buy it.
 

·
Premium Member
Joined
·
1,392 Posts
Discussion Starter · #7 ·
I that case I'll trust that you're impartial ;)
I'm gonna wait until I get my new Mac in January, but i'll probs go with Amplitube. The only thing is, all of these clips have been fairly low gain lead tones. How does it do for higher gain stuff. Not necessarily modern 'brutal' metal, but harder rock tones etc. ?

Ps. Sorry for all the questions but it's not really something I can try before I buy it.
It does hard rock tones really well. It's just that I've been finding myself leaning towards less gain lately.

Get the demo of Amplitube from the IK site - if you can get that, I'll send you some of my patches so you can have a muck about, if you like.
 

·
Pallin' around
Joined
·
9,532 Posts
I don't know why, but I can't get good tones worth shit with Amplitube 3. All the sounds I get have that low end swell, where the bottom string overtakes everything with a: wwwwwwwwwoooOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

:(
 

·
Premium Member
Joined
·
1,392 Posts
Discussion Starter · #10 ·
I don't know why, but I can't get good tones worth shit with Amplitube 3. All the sounds I get have that low end swell, where the bottom string overtakes everything with a: wwwwwwwwwoooOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

:(
Hmm. How are you running it?
 

·
Pallin' around
Joined
·
9,532 Posts
I just run its in Reaper, load it as a VSTi, and then post EQ it to try to get the swell out, but the only way I have been able to do that is by putting a high pass at like 300 db, which really makes the sound very thin.

Sorry about the thread highjack too :(
 
1 - 13 of 13 Posts
Top